Download Error

Incident Report for UpLead

Resolved

The issue with downloads showing an error message has been resolved.
Posted Apr 17, 2024 - 01:07 UTC

Update

We are continuing to investigate this issue.
Posted Apr 16, 2024 - 20:54 UTC

Investigating

We are currently investigating an error that is occurring upon download.
Posted Apr 16, 2024 - 20:52 UTC
This incident affected: Management Portal (app.uplead.com).